Diposting oleh

Setting Mikrotik dan Setting Proxy ArmadaNet Pekanbaru

Diposting oleh
Setting Mikrotik dan Setting Proxy ArmadaNet Pekanbaru - jasa setting mikrotik dan proxy warnet di pekanbaru, setting mikrotik rb750 di warnet armadanet Jl. Sail No.107 Gg. Perwira, Kel. Rejosari, Tenayan Raya, Pekanbaru, Riau.


Koneksi internet yang di gunakan Armadanet 3line Speedy, dan di tambah media penghemat bandwidth dan cache video youtube, update game dengan proxy untuk menghemat bandwidth armada net, dengan client 30 unit client dan koneksi internet speedy menggunakan 3 line speedy, yang rencananya 2mbps + 2mbps + 2mbps dengan konsep loadbalancing.

User rata-rata armadanet penggila game point blank sehingga prioritas untuk game ini di utamakan, dan limit terhadap extensi yang sering di download harus di lakukan untuk mengatasi pemborosan bandwidth yang ada. Metoda limit bandwidth adalah queue tree.

Berikut ini limit bandwidth per extensi dengan queue tree

add name=YOUTUBE regexp="http/(0\\.9|1\\.0|1\\.1)[\\x09-\\x0d ][1-5][0-9][0-9][\\x09-\\x0d -~]*(content-type: video)"
add name=EXE regexp="\\.(exe)"
add name=RAR regexp="\\.(rar)"
add name=7z regexp="\\.(7z)"
add name=CAB regexp="\\.(cab)"
add name=ASF regexp="\\.(asf)"
add name=MOV regexp="\\.(mov)"
add name=WMV regexp="\\\\.(wmv)"
add name=MPG regexp="\\.(mpg)"
add name=MPEG regexp="\\.(mpeg)"
add name=MKV regexp="\\.(mkv)"
add name=ZIP regexp="\\\\.(zip)"
add name=AVI regexp="\\.(avi)"
add name=FLV regexp="\\.(flv)"
add name=WAV regexp="\\.(wav)"
add name=RM regexp="\\.(rm)"
add name=MP3 regexp="\\.(mp3)"
add name=MP4 regexp="\\.(mp4)"
add name=RAM regexp="\\.(ram)"
add name=RMVB regexp="\\.(rmvb)"
add name=DAT regexp="\\.(dat)"
add name=DAA regexp="\\.(daa)"
add name=ISO regexp="\\.(iso)"
add name=NRG regexp="\\.(nrg)"
add name=BIN regexp="\\.(bin)"
add name=VCD regexp="\\.(vcd)"
add name=3GP regexp="\\.(3gp)"
Jika ingin sekali paste rule layer 7 mikrotiknya, coba gunakan yang berikut ini

Layer 7 extensi mikrotik dalam bentuk yang lain
/ip firewall layer

add name=download regexp="^.*get.+\.(exe|rar|zip|7z|cab|asf|mov|wmv|mpg|mpeg|mkv|avi|flv|pdf|wav|rm|mp3|mp4|ram|msu|msi|nup|vdf|rmvb|dat|daa|iso|nrg|bin|vcd|mp2|3gp|mpe|qt|raw|wma|ogg|doc|deb|tar|bzip|gzip|gzip2|0[0-9][0-9]).*$"
add name=video regexp="^.+.c.youtube.com.*\$"

Berikut mangle per extensinya.

/ip firewall mangle
add action=mark-connection chain=prerouting comment=GAME disabled=no dst-port=1818,2001,3010,4300,5105,5121,5126,5171,5340-5352,6000-6152,7777 new-connection-mark=\
    game_conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting disabled=no dst-port=7341-7350,7451,8085,9600,9601-9602,9300,9376-9377,9400,9700,10001-10011 new-connection-mark=game_conn \
    passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting disabled=no dst-port=10402,11011-11041,12011,12110,13008,13413,15000-15002,16402-16502,16666,18901-18909,19000 \
    new-connection-mark=game_conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting disabled=no dst-port=19101,22100,27780,28012,29000,29200,39100,39110,39220,39190,40000,49100 new-connection-mark=game_conn \
    passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting disabled=no dst-port=14009-14010 new-connection-mark=game_conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting disabled=no dst-port=14009-14010 new-connection-mark=game_conn passthrough=yes protocol=udp
add action=mark-connection chain=prerouting disabled=no dst-port=1293,1479,6100-6152,7777-7977,8001,9401,9600-9602,12020-12080,30000,40000-40010 new-connection-mark=\
    game_conn passthrough=yes protocol=udp
add action=mark-connection chain=prerouting disabled=no dst-port=42051-42052,11100-11125,11440-11460 new-connection-mark=game_conn passthrough=yes protocol=udp
add action=mark-packet chain=prerouting connection-mark=game_conn disabled=no new-packet-mark=game_pkt passthrough=no
add action=mark-packet chain=forward disabled=no dscp=12 in-interface=ether13 new-packet-mark=hit passthrough=no protocol=tcp
add action=mark-packet chain=forward comment="YOUTUBE MARK" disabled=no layer7-protocol=YOUTUBE new-packet-mark=YOUTUBE passthrough=no
add action=mark-packet chain=forward comment="WMV MARK" disabled=no layer7-protocol=WAV new-packet-mark=WMV passthrough=no
add action=mark-packet chain=forward comment="EXE MARK" disabled=no layer7-protocol=EXE new-packet-mark=EXE passthrough=no src-address-list=!PROXY
add action=mark-packet chain=forward comment="ZIP MARK" disabled=no layer7-protocol=ZIP new-packet-mark=ZIP passthrough=no
add action=mark-packet chain=forward comment="RAR MARK" disabled=no layer7-protocol=RAR new-packet-mark=RAR passthrough=no
add action=mark-packet chain=forward comment="MPG MARK" disabled=no layer7-protocol=MPG new-packet-mark=MPG passthrough=no
add action=mark-packet chain=forward comment="MPEG MARK" disabled=no layer7-protocol=MPEG new-packet-mark=MPEG passthrough=no
add action=mark-packet chain=forward comment="MP3 MARK" disabled=no layer7-protocol=MP3 new-packet-mark=MP3 passthrough=no
add action=mark-packet chain=forward comment="MOV MARK" disabled=no layer7-protocol=MOV new-packet-mark=MOV passthrough=no
add action=mark-packet chain=forward comment="ISO MARK" disabled=no layer7-protocol=ISO new-packet-mark=ISO passthrough=no
add action=mark-packet chain=forward comment="MKV MARK" disabled=no layer7-protocol=MKV new-packet-mark=MKV passthrough=no
add action=mark-packet chain=forward comment="FLV MARK" disabled=no layer7-protocol=FLV new-packet-mark=FLV passthrough=no
add action=mark-packet chain=forward comment="AVI MARK" disabled=no layer7-protocol=AVI new-packet-mark=AVI passthrough=no
add action=mark-packet chain=forward comment="CAB MARK" disabled=no layer7-protocol=CAB new-packet-mark=CAB passthrough=no
add action=mark-packet chain=forward comment="ASF MARK" disabled=no layer7-protocol=ASF new-packet-mark=ASF passthrough=no
add action=mark-packet chain=forward comment="WAV MARK" disabled=no layer7-protocol=WAV new-packet-mark=WAV passthrough=no
add action=mark-packet chain=forward comment="RM MARK" disabled=no layer7-protocol=RM new-packet-mark=RM passthrough=no
add action=mark-packet chain=forward comment="RAM MARK" disabled=no layer7-protocol=RAM new-packet-mark=RAM passthrough=no
add action=mark-packet chain=forward comment="RMVB MARK" disabled=no layer7-protocol=RMVB new-packet-mark=RMVB passthrough=no
add action=mark-packet chain=forward comment="DAT MARK" disabled=no layer7-protocol=DAT new-packet-mark=DAT passthrough=no
add action=mark-packet chain=forward comment="DAA MARK" disabled=no layer7-protocol=DAA new-packet-mark=DAA passthrough=no
add action=mark-packet chain=forward comment="NRG MARK" disabled=no layer7-protocol=NRG new-packet-mark=NRG passthrough=no
add action=mark-packet chain=forward comment="BIN MARK" disabled=no layer7-protocol=BIN new-packet-mark=BIN passthrough=no
add action=mark-packet chain=forward comment="3GP MARK" disabled=no layer7-protocol=3GP new-packet-mark=3GP passthrough=no
add action=mark-connection chain=forward comment=LIMIT disabled=no new-connection-mark=users-con passthrough=yes src-address=192.168.100.0/24
add action=mark-packet chain=forward connection-mark=users-con disabled=no new-packet-mark=users passthrough=yes

Set queue treenya untuk hit proxy dan game serta otomatis bagi bandwidth

/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=1.HIT packet-mark=hit parent=ether2 priority=1 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=512k name="LIMIT FILE EXTENTION" parent=global-out priority=3
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=128k name=AVI packet-mark=AVI parent="LIMIT FILE EXTENTION" priority=3 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=128k name=EXE packet-mark=EXE parent="LIMIT FILE EXTENTION" priority=3 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=128k name=FLV packet-mark=FLV parent="LIMIT FILE EXTENTION" priority=3 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=384k name=YOUTUBE packet-mark=YOUTUBE parent="LIMIT FILE EXTENTION" priority=3 queue=\
    default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=128k name=ISO packet-mark=iso parent="LIMIT FILE EXTENTION" priority=3 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=128k name=MP3 packet-mark=MP3 parent="LIMIT FILE EXTENTION" priority=3 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=128k name=MP4 packet-mark=MP4 parent="LIMIT FILE EXTENTION" priority=3 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=128k name=MPEG packet-mark=MPEG parent="LIMIT FILE EXTENTION" priority=3 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=128k name=MPG packet-mark=MPG parent="LIMIT FILE EXTENTION" priority=3 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=128k name=RAR packet-mark=RAR parent="LIMIT FILE EXTENTION" priority=3 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=128k name=WMV packet-mark=WMV parent="LIMIT FILE EXTENTION" priority=3 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=64k name=ZIP packet-mark=ZIP parent="LIMIT FILE EXTENTION" priority=3 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=128k name=CAB packet-mark=CAB parent="LIMIT FILE EXTENTION" priority=3 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=128k name=ASF packet-mark=ASF parent="LIMIT FILE EXTENTION" priority=3 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=128k name=MOV packet-mark=MOV parent="LIMIT FILE EXTENTION" priority=3 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=128k name=MKV packet-mark=MKV parent="LIMIT FILE EXTENTION" priority=3 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=128k name=WAV packet-mark=WAV parent="LIMIT FILE EXTENTION" priority=3 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=128k name=RM packet-mark=RM parent="LIMIT FILE EXTENTION" priority=3 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=128k name=RAM packet-mark=RAM parent="LIMIT FILE EXTENTION" priority=3 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=128k name=RMVB packet-mark=RMVB parent="LIMIT FILE EXTENTION" priority=3 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=128k name=DAT packet-mark=DAT parent="LIMIT FILE EXTENTION" priority=3 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=128k name=DAA packet-mark=DAA parent="LIMIT FILE EXTENTION" priority=3 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=128k name=NRG packet-mark=NRG parent="LIMIT FILE EXTENTION" priority=3 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=128k name=BIN packet-mark=BIN parent="LIMIT FILE EXTENTION" priority=3 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=128k name=3GP packet-mark=3GP parent="LIMIT FILE EXTENTION" priority=3 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=2.GAME packet-mark=game_pkt parent=global-total priority=2 queue=Game
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=784k name=queue1 packet-mark=users parent=ether2 priority=8 queue=pcq-down
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=128k name=queue2 packet-mark=users parent=ether1 priority=8 queue=pcq_upload

Perhatikan Parent=ether2 yang saya bold, parent tersebut merupakan interface ke lokal.

Set queue Typenya seperti berikut, paste saja di terminal winbox mikrotik
/queue type

add kind=pcq name=Game pcq-burst-rate=0 pcq-burst-threshold=0 pcq-burst-time=10s pcq-classifier=src-address,dst-address,src-port,dst-port pcq-dst-address-mask=32 \
    pcq-dst-address6-mask=64 pcq-limit=50 pcq-rate=0 pcq-src-address-mask=32 pcq-src-address6-mask=64 pcq-total-limit=2000

add kind=pcq name=pcq_upload pcq-burst-rate=0 pcq-burst-threshold=0 pcq-burst-time=10s pcq-classifier=src-address pcq-dst-address-mask=32 pcq-dst-address6-mask=64 \
    pcq-limit=50 pcq-rate=0 pcq-src-address-mask=32 pcq-src-address6-mask=64 pcq-total-limit=2000

add kind=pcq name=pcq-down pcq-burst-rate=0 pcq-burst-threshold=0 pcq-burst-time=10s pcq-classifier=dst-address pcq-dst-address-mask=32 pcq-dst-address6-mask=128 \
    pcq-limit=50 pcq-rate=32k pcq-src-address-mask=32 pcq-src-address6-mask=128 pcq-total-limit=2000

Semoga setting limit per extensi mikrotik yang saya terapkan di armadanet pekanbaru ini bermanfaat bagi anda, dan jika anda membutuhkan jasa setting mikrotik dan jasa setting proxy external lusca untuk cache youtube, cache update game, setting wireless, setting hotspot, anda bisa menghubungi Jasa setting mikrotik





Tidak ada komentar:

Posting Komentar